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Before you Start

For Everyone

Before you start MILCON COACH, you should know how to use Microsoft Windows, including how to do the following:

· Use Program Manager and File Manager

· Use the mouse (click, double-click, and drag)

· Move around in a window and use the scroll bars

· Move, resize, and close a window

· Choose commands from menus and select options in dialog boxes

· Locate, open, copy, and delete files

Refer to your Microsoft Windows User’s Guide for more information on any of these techniques.

Introducing MILCON COACH

MILCON COACH adds integrated project management capabilities and additional features to the Microsoft Windows version 3.1 operating system..  With MILCON COACH at you fingertips you can work with and maintain your projects more effectively and efficiently.  

This booklet describes how to install and use the MILCON COACH software program.

System Requirements

Your computer and system software must meet the following minimum requirements to run MILCON COACH 1.0.

Component
Minimum

Computer
80386

RAM
4 MB

Monitor
VGA

3 1/2 inch floppy drive


Mouse


DOS
3.3

Microsoft Windows version
3.1

Microsoft Word for Windows
6.0

Microsoft Excel for Windows
4.0

Microsoft Project for Windows
4.0

You will need approximately 20 MB available on your hard drive to install the full version of MILCON COACH 1.0 and all of its program files.  If you do not want to install the full version you will be prompted during installation whether or not to install the following four programs.

1. PD TUTOR
2.5 MB

2. A-E Acquisition Online Guide
0.3 MB

3. RAMP Online Guide
0.1 MB

4. Project Definition Guide
4.0 MB

Installing MILCON COACH 1.0

There are a few things you can do prior to installation to ensure it goes smoothly.  First, turn off any virus-protection software you have running to avoid interference with MILCON COACH Setup.  Next, close any Windows programs you have running.  This frees up memory for installation and prevents possible conflicts between MILCON COACH Setup and other programs.

To install MILCON COACH 1.0:

1. Insert the Setup disk (DISK 1) in the appropriate disk drive

2. From the Program Manager File menu, choose Run

3. In the Run dialog box type the following command, substituting the letter of your drive A, and press Enter.  a:\setup

4. Follow the instructions on your screen

After you run Setup, you will wee a program group in the Windows Program Manager called COACH.

What Setup Installs

The MILCON COACH Setup program copies the files listed below into the disk drive you selected.  The Setup program creates a MI1COACH directory on you hard disk and copies into it several subdirectories and files.  The following table lists the directories created and the groups of files the Setup program installs.

Directory Created
Files Installed

\MI1COACH
*.BMP


*.DLL


MILCOACH.EXE


MVIEWER2.EXE


COACH.ICO


MILCOACH.INI


MILCON.LDB


VSVBX.LIC


LESSON.MDB


MILCON.MDB


TUTOR.MVB


LESSON.RPT


README.TXT


*.VBX


*.XTD

\MI1COACH\FORM
*.DOC


*.XLS


*.MPP

\MI1COACH\GUIDES
ACQ.DOC


PD.DOC


RAMP.DOC

MILCON COACH 1.0 Installation

Following are the screens you will see during the installation of MILCON COACH.

Insert install.bmp, copying.bmp, insert.bmp, option1, option2, option3, option4, pmid.tiff, readme.tiff, progman.tiff

Starting MILCON COACH 1.0

Once the program installation is complete, you can start MILCON COACH 1.0 by double-clicking the COACH icon in the Program Manager.

Insert progman.tiff here

Beginning Work in MILCON COACH 1.0

When you start MILCON COACH 1.0, you see the entry graphic (click OK), then you see the main MILCON COACH screen.

Insert startup.tiff

The Main MILCON COACH Screen

The following illustration shows some important parts of the main MILCON COACH screen, followed by a brief description of each screen part.

Insert BASIC

Title bar
Displays “MILCOACH” and the name of the current project.

Menu bar
Contains a list of menus.  You open menus and then choose commands from them to instruct MILCON COACH to perform actions.

Toolbar
with the mouse, provides instant access to some MILCON COACH commands (addnew, save, delete, cut, copy, paste, print, and find).

Note:
Once you have created a project the screen shown below will default to start on the last project you worked on prior to exiting MILCON COACH.

Insert project

Helping You Get Around in MILCON COACH

Setting up a new project

MILCON COACH allows you to set up multiple projects within the software and it creates new files and subdirectories within your program to store data and documents unique to each project.

To set up a new project, from the Menu bar, choose File New project

MILCON COACH displays the New Project Parameters dialog box.

Insert project

PDC Number
Enter the project’s six digit PDC number.  If you have a project which is being phased and you want to track each phase separately, also enter a dash (-) and a two digit phase number, e.g. 123456-78.

Project Name
Enter the project’s name.

Parameters

Category Code
Select the {down arrow} then choose the category code of the new project.

Air Force Base
Select the {down arrow} then choose the name of the Air Force Base of the new project.  The default list is only the 86 CONUS bases.  If your project is on an installation not listed, select {Exit} and go to Options on the Command bar and select Edit Base.  You can enter a new installation name in these fields.

Design Agent
Select which organization is to be the agent for this new project.

Work Type
Select if the project is an Add/Alter project or New Construction.  If it is some of both, select Add/Alt.

Key Word
This field allows you to enter key words that allows you to search for advice for unique characteristics.  

Example:  Your new project may require TEMPEST shielding.  Selecting TEMPEST from the key word list will cause the program to search the database for advice for all references to TEMPEST, even if it is for a different category code of project.

Save
Select Save when you are satisfied with the new project’s parameters.  The minimum amount of data you can open a new project with is the PDC number and the base location. (These two facts establish the project’s directory and subdirectory structure on your computer’s hard drive). 

When you select Save, MILCON COACH creates a new file directory.  You will also be prompted to create a forms directory which will contain copies of all of the document files you will need on the new project.  The prompt will also let you know how much free disk space will remain on your hard drive after creation of the subdirectory.

Note:
If you have already set up a new project but need to change any of the parameter fields, don’t set up a different project.  Go to the Menu bar and choose Options Edit project.  This screen allows you to modify all of the parameters with the exception of the Base and PDC number.

Deciding and selecting which forms to copy

As you set up a new project and save the project parameters to the hard drive, you are given the opportunity to save copies of all of the generic files of documents you will need during the management of the project.  

After you save the New Project parameters the Select dialog box is displayed.

Insert select

This dialog box lists all of the files by filename, description, and bytes or size of the files.  Initially when this dialog box is displayed all of the files are selected, (they should be highlighted in blue).  You can either click OK now to copy all of these files or click your mouse on the individual files to de-select the ones you do not want.  Next, click OK to copy these files.  This will set up a new subdirectory with a name based on the four character code of the base with a subdirectory of the specific project.  This project subdirectory is named for the six digit PDC code number for the project and this is where all of the “products” files are copied.

You are given a warning of how much free disk space will remain on your hard drive at the completion of saving the new project.  If you have insufficient disk space, either select Cancel and saving the project will be aborted, or de-select specific files on the list by clicking on them.  This will reduce the amount of disk space required to create a new project on your hard drive.

If sufficient space is available, select OK.

Working with current projects

After you have set up at least one project, the next time you launch MILCON COACH, the current projects dialog box is automatically displayed.

Insert current

This dialog box allows you to quickly select which of your current projects you want to work on now.  It will always default to the last active project when you last exited MILCON COACH, so if you want to work on that project again, select {OK}

Project Manger
This field will default to the project manager’s name entered during the initial setup of MILCON COACH on your computer.  If this is not your name and you want to change it, you can edit it each time you select a current project; however, you will get tired of this routine.  The other way to change the default project manager’s name is to edit the milcoach.ini file to change the user’s name.  To do this, go to the File Manager program and select the mi1coach directory which should be located under your root directory or the drive you selected during program installation.  Double-click on the milcoach.ini file and edit only the user’s name.

Air Force Base
This pick list contains all of the Air Force Base names where there are active projects stored within your copy of MILCON COACH.  To change the currently active project to a project on a different base, select the {down arrow} and pick the base you want to be active.  The four character PDC designation for that base will automatically become the active project location.

Project
If you have multiple active projects on one base, this pick list allows you to select the PDC number of the project you want to be the active project.

OK
When the project you want to access is correct, select {OK} and you will be able to access Advice on the Menu bar for that project.  The drop-down menu below the Advice command lists the phases of the MILCON process for which you can access advice in your edition of MILCON COACH.  Simply select the phase you need advice on and another pop-up screen will appear. That screen allows you to select a particular subphase of the process or all of the subphases.   Selecting {OK} scans the database for advice on the phases selected.

Cancel
If you want to exit the program or set up a new project, select {Cancel}.  If you’re setting up a new project, from the File menu select New project.  This accesses a dialog box titled New Project Parameters.

Editing project parameters

Just like setting up a new project, you can modify the current parameters (all except the base location and PDC number), to reflect changes in your project.  These changes affect the sorting of the advice in the MILCON COACH database.  

From the Options menu, choose Edit project.  The Project Parameters dialog box will be displayed with the current project’s parameters.

Insert project

This is the same screen you used to set up a new project but it contains the current project data now.

Make the necessary changes and then select the Save icon on the toolbar or the Save Project command under the File menu.

Working with existing advice

From the menu bar, you can select Advice.  Five phases of advice are currently available.  These phases are Requirement Document, Project Management Plan, A-E Procurement (Air Force Agent), A-E Procurement (Non Air Force Agent), and Project Definition.

Depending on which phase of advice you select to work with, the following screen is an example of what you will find.  The Project Definition Advice phase was selected here.

Insert advice

Next, select which subphase you would like advice on.  Notice you can select just one topic, several topics, or all of them.  Use the SHIFT key or the CONTROL key with a mouse click to select multiple subphases.

After you have made your selection(s) click the OK button.  MILCON COACH will collect all of the available advice on the subphase(s) you selected.  The advice is displayed by the three categories -- people, process, and products as shown in the dialog box below.

Insert advice-2

The product tab is a little different from the people and process tabs.  There is a pick list of available products to choose from on the products tab.

Insert product 

Now that you are in the Product portion of the advice information, you see a pick list of various product files.  These are electronic documents prepared in either Microsoft Word, Excel or Project.

You may launch any of these files simply by double-clicking on the file name, just like you do on an individual file when you are in the File Manager program.  The application the document was created in is launched and the file is opened.

You may edit this file to the specific requirements of your project.

Setting up or revising advice

MILCON COACH allows you to customize your copy of the software by adding or revising the  advice and adding more documents to the products pick lists.  This is helpful, particularly with advice you want to add which is base and project category specific.

Insert revise

Adding Advice
By adding advice, you do not affect the advice that came with your original MILCON COACH software.  You simply augment this advice with additional advice.  The system generated advice and your added advice are both displayed on the People, Process, and Products advice screens.

1. To add advice, from the Options menu, select Add/Revise Advice, then when the Setup/Revise Advice dialog box displays, select the addnew icon from the upper left corner of the tool bar.  (This icon looks like a clean sheet of paper with a corner turned down).  This creates a new record field for your new advice.  It will have an advice number assigned to it by MILCON COACH.

2. Enter a short description, normally referring to the phase of the project the advice deals with.

3. Next is the important part - selecting the parameters of a project that you want the advice to apply.

a. First select the Phase of the process the advice deals with.  By clicking on the down arrow to the right of the phase field, all of your choices are provided.

b. Next, select the Sub Phase in the same manner.

c. Now you must select the remaining parameters which relate to the new advice.  Select only those parameters which apply - The Category Code, the base, the design agent and the type of work.

Example 1
If your new advice applies to all runway projects, regardless of the location, who is the agent, and/or if its a new or add/alt project; select only the Category Code for runways.

Example 2
If your advice applies only to an new avionics building on Homestead AFB with the Corps of Engineer as the agent, select each of these and then check the box titled “Check for Exact Match.”  This will cause the new advice to be loaded only when all conditions are met.

d. If your advice is true for more than one parameter, i.e. equally true for an add/alt or a new construction project, you will have to create more than one record of new advice -  One with the Work Type: Add/Alt selected and the other with the Work Type: New selected.

4. Now you are ready to enter the new advice.  Simply type the advice directly into the fields below the People, Process, and Products tabs (choose the people tab, then the process tab, and finally the products tab).  It is wise to select Save after entering each tab of information to prevent loosing any data.

5. When you are ready to enter the advice in the Products field, you will notice the size of the field changes and two new tabs appear on the right side of the field:  Advice and Form.  These two tabs change the field from an advice field into a field where you enter products you want to be able to launch from MILCON COACH.  If you want to install new products into the new advice record, you must first set up the products through the File Manager application.  See the procedures for doing this in Setup/Revise File Description
6. If you have not previously set up the product files as described in Setup/Revise File Description, you must save your new advice record and do the file set up first.  

Note:
Before exiting the Setup/Revise Advice screen, remember the Advice Number in the upper left corner of the dialog box.  You will need to return to it later to install the products into your advice record.

7. When the products have been set up as described in Setup/Revise File Description, return to the Setup/Revise Advice screen and scroll to the Advice Number of the record you left earlier.  You do this by clicking the right arrow keys in the lower right corner of the dialog box.  

8. When you return to the appropriate record where you want the product installed, open the Products/Form field.  A two part field will open with a down arrow separating the two parts.  Click on the down arrow and a listing of all products available within MILCON COACH will appear.  Scroll down until the product file you want is selected.  Click on this file and it will be applied to the product pick list.  Now, move the cursor directly below the last file on the product pick list and click you mouse button.  This will open a new blank field below the last file.  Next, select Save and then Exit.  This will take you back to the normal MILCON COACH screen and you can test your work to see if you installed your new advice correctly.

9. If you need to create several records that have many of the same attributes or advice, you may highlight, copy and paste the data between the different records, making sure you save the data each time you leave an advice record.

Adding and Revising Bases

The default list of Air Force Bases in this version of MILCON COACH is the 86 current CONUS bases.  You can add other installations to this list by selecting the Add/Revise Bases command under the Options menu.  The miscellaneous code maintenance dialog box will be displayed.  

Insert revi-b

From the toolbar select the addnew icon and then simply add the PDC installation code and the installation name by typing the PDC code in the Base Code field and the installation name in the Base Name field.

Select the save icon on the toolbar or the Save Project command from the File menu.

Setup/Revise files and forms for the advice screens

MILCON COACH allows you to add new products/documents which can be accessed from the advice screens you create and revise using the Add/Revise Advice command.  There are several steps to go through but you will be proud of the results.

1. Create the new document that you want to add to MILCON COACH.  These new documents must be created in either Microsoft Word, Microsoft Excel, or Microsoft Project.

2. Save the new document into the Form subdirectory under the mi1coach directory.  

3. Next, open MILCON COACH and select Cancel on the Current Project dialog box.

4. Now, select Setup/Revise File Description from the Option menu.  This displays a dialog box called Form Description which lists all of the files currently available in the MILCON COACH form subdirectory

Insert form screen 

5. On the Form Description list, scroll down until you find the new file you saved in the \mi1coach\form subdirectory.  There will be a blank space to the right of this file under the column titled Description.

6. Type a brief description (less than 35 characters and spaces), of the new file.

7. You can now make this file accessible from the Products pick list of the Advice screens through the procedures described in the Setup/Revise Advice procedures.

See also Setup/Revise Advice
Lesson learned (specific notes for your projects)

MILCON COACH has the ability to allow you to capture the knowledge which you gain through experience so future editions of MILCON COACH can pass this advice on to others, the next generation of Air Force Project Managers.

This Lesson Learned knowledge is captured under the Notes menu. On a periodic basis, your MAJCOM will collect this knowledge and an Air Force wide PAT team will initiate program revisions incorporating your new advice.

To record lessons learned select Add Lessons Learned from the Notes menu.

The Lesson Learned dialog box is displayed.  Click the addnew button from the toolbar.  The project manager’s name will be filled into the Author field as well as the current date in the Date field.

Insert Lesson graphic

Enter the category code and a brief description of you lesson learned in the two small fields.  Then type a detailed description of the issue in the test field.  When you are finished, click on the File Save icon on the tool bar.

Print Lessons Learned
At anytime, you can print a copy of the lessons learned by selecting this option under the Notes command.  You have a choice before printing to review the records on screen before printing.

Archive Lessons Learned
On a periodic basis, your MAJCOM will collect copies of the Lessons Learned from all Air Force Project Mangers.  To do so, select Archive Lessons Learned from the Notes menu and save the file as an Access MDB (*.mdb) database file onto a floppy disk.  These will be collected and reviewed for inclusion in the next release of MILCON COACH.

Clear All Lessons Learned
You may clear your Lesson Learned file at any time by selecting this from the Notes menu.

Online Guides

MILCON COACH allows you to save and retrieve electronic copies of the complete text of the Air Force Project Manager’s Guides for:

A-E Acquisition

Project Definition

RAMP

As other guides are created, these will be added to future releases of MILCON COACH.

You are asked at the time of MILCON COACH installation if you want to add these in your computer’s hard drive.  They normally require more than a meg of storage space, but they may come in handy as a reference to you if you have a notebook computer and you are away from your office.

To use the Online Guides, from the Help menu select Online Guides and then select the guide you want to review.  Microsoft Word will be launched automatically and the document displayed for your use.  To return to MILCON COACH, simply exit Microsoft Word.

PD Tutor

At the original installation of MILCON COACH, you are given the opportunity to load a computer based training tool called PD Tutor.  This deals with an in-depth look at the Project Definition phase of Air Force projects.

If you elect to load this tutorial on your hard drive, it will require approximately 3.7 megs of hard drive space.

To access PD Tutor, select PD tutor from the Help menu.  The PD tutor point and click program is launched for you.

Insert PD tutor graphic

Operation of PD Tutor  -  The first screen of PD Tutor is your road map of the Project Definition process.  You can navigate directly to the subphase you want to know more about, and the people, process, and products involved in this phase. 

You can also see an overview of the PD process by selecting the Overview Icon near the lower left of the main menu PD tutor screen.

Whenever you want to go to the next phase of Project Definition, select the Main Menu button icon in the upper right corner to return to the main menu PD tutor screen.  You must also do this to navigate between the People, Process, and Products of each phase.  This is done to keep the user aware of which phase they are viewing.  The phasing bar at the top of the individual screens also serve as a reminder of which phase you are viewing.

To return to MILCON COACH select the exit icon in the lower left corner of the main menu PD tutor screen.

Using the Supervisor Menus

The Login Supervisor command under the Help menu allows an Air Force systems operator assigned at each MAJCOM to tailor the MILCON COACH software to their specific procedures.

You must be an assigned supervisor to access this portion of the program.

To access the supervisor functions, select Login Supervisor from the Help menu.  You will be prompted for a password.  Type the password and click OK.

Insert password graphic

Notice another menu item has been added called System.  From the System menu you can Change the Supervisor Password, Setup/Revise Advice, and Add/Revise Miscellaneous.

Change the Supervisor Password by typing the new password in the Please enter the new password field and then re-entering the password for confirmation in the next field.  Select OK after the changes have been made and you now have a new password.

The Setup/Revise Advice choice in the supervisor part of MILCON COACH enables the supervisor to change or revise the existing advice distributed with the current release of MILCON COACH.  Your MAJCOM may have specific procedures and authorization level of approval which must be followed prior to any revisions.  Make sure you have the proper authorization before making modifications.
To work on the supervisor level of Setup/Revise Advice, select Setup/Revise Advice from the System menu.  The Setup/Revise Advice dialog box displays.

Insert advice screen

Adding Advice  -  By adding new advice records, you do not affect the advice that came with your original MILCON COACH software.  You simply augment this advice with additional advice.  The original system generated advice and your added advice are both displayed on the People, Process, and Products advice screens.

Adding Advice and Documents
1. To add advice, select the add new icon from the upper left corner of the tool bar.  (This icon looks like a clean sheet of paper with a corner turned down).  This creates a new record field for your addition.  It will have an advice number assigned to it by the program.

2. Enter a short description, normally referring to the phase of the project the advice deals with.

3. Next is the important part - selecting the parameters of a project that you want the advice to apply.

a. First select the Phase of the process the advice deals with.  By clicking on the down arrow to the right of the field, all of your choices are provided.

b. Next, select the Sub Phase in the same manner.

c. Now you must select the remaining parameters which relate to the new advice.  Select only those parameters which apply - The Category Code, the base, the design agent and the type of work.

Example 1
If your new advice applies to all runway projects, regardless of the location, who is the agent, and or if its a new or add/alt project; select only the Category Code for runways.

Example 2
If your advice applies only to an new avionics building on Homestead AFB with the Corps of Engineer as the agent, select each of these and then select the box titled “Check for Exact Match.”  This will cause the new advice to be loaded only when all conditions are met.

d. If your advice is true for more than one parameter, e.g. equally true for an add/alt or a new construction project, you will have to create more than one record of the new advice -  One with the Work Type: Add/Alt selected and the other with the Work Type: New selected.

4. Now you are ready to enter the new advice.  Simply type the advice directly into the fields below the People, Process, and Products tabs.  It is wise to select Save after entering each field to prevent loosing any data.

5. When you are ready to enter the advice in the Products field, you will notice that the size of the field changes and two new tabs appear on the right side of the field - Advice and Form.  These two tabs change the field from an advice field into a field where you enter products that you want to be able to launch from MILCON COACH.  If you want to install new products into the new advice record, you must first set up the products through the Microsoft File Manager application.  See the procedures for doing this in Setup/Revise File Description
6. If you have not previously set up the product files as described in Setup/Revise File Description, you must save your new advice record and do the file set up first.  

Note:
Before exiting the Setup/Revise Advice screen, remember the Advice Number in the upper left corner of the dialog box.  You will need to return to it later to install the products into your advice record.

7. When the products have been set up as described in Setup/Revise File Description, return to the Setup/Revise Advice screen and scroll to the Advice Number of the record you left earlier.  You do this by clicking the right arrow keys in the lower right corner of the dialog box.  

8. When you return to the appropriate record where you want the product installed, open the Products/Form field.  A two part field will open with a down arrow separating the two parts.  Click on the arrow and a listing of all products available within MILCON COACH will appear.  Scroll down until the product file you want is selected.  Click on this file and it will be applied to the product pick list.  Now, move the cursor directly below the last file on the product pick list and click you mouse button.  This will open a new blank field below the last file.  Now, select Save and then Exit.  This will take you back to the normal MILCON COACH screen and you can test your work to see if you installed your new advice correctly.

9. If you need to create several records that have many of the same attributes or advice, you may highlight, copy and paste the data between the different records, making sure you save the data each time you leave an advice record.

Revising Advice and Documents

Revising advice is handled in an almost identical method as adding advice.  The only difference is that instead of creating a new database record for new advice, you simply make changes to an existing record.  To do so requires you to scroll through the existing records in the Setup/Revise Advice dialog box until the correct screen appears.  You need to confirm that the parameters dealing with that advice record reflect the conditions that apply the conditions for the revision that you want to make.  Many advice fields look very similar, but apply to differing parametric conditions.

Revising Documents requires that you open the individual document files through File Manager.  The documents are all filed on the C:\mi1coach\form subdirectory.  Opening these generic forms, editing them, and re-filing them will permanently modify them.  Make sure that you receive approval authorization before attempting this.   

Set up Miscellaneous Tables

This set up table allows the system operator to make additions and corrections to the fields of the new project parameters set up screen.  The operator makes these changes as follows:

To make changes or add new Category Codes 

1. Select the Category tab.

2. Click the addnew button on the toolbar

3. Enter the new category code numbers in the Category Code field.

4. Describe the new category in the Description field

5. Select Save from the File menu bar or click the file save icon on the toolbar.

To make changes or add new Agents
1. Select the Agent tab.

2. Click the addnew button on the toolbar

3. Enter the new agent name in the blank Agent field.

4. Select Save from the File menu bar or click the file save icon on the toolbar.

To make changes or add new Keywords
1. Select the Keyword tab.

2. Click the addnew button on the toolbar

3. Enter the new keyword in the blank Keyword field.

4. Select Save from the File menu bar or click the file save icon on the toolbar.

5. If you need to modify an existing keyword, select it from the list and modify it in the Keyword field, then save it.

To make changes or add new Bases
1. Select the Base tab.

2. Click the addnew button on the toolbar

3. Enter the new Base four character code in the blank Base Code field.

4. Enter the base’s name in the Base Name field.

5. Select Save from the File menu bar or click the file save icon on the toolbar.

6. If you need to modify an existing Base, select it from the list and modify the appropriate field, then save it.

To make changes or add new Worktypes
1. Select the Worktype tab.

2. Click the addnew button on the toolbar

3. Enter the new Worktype in the blank Worktype field.

4. Select Save from the File menu bar or click the file save icon on the toolbar.

5. If you need to modify an existing Worktype, select it from the list and modify it in the Worktype field, then save it.

